Twine kills my local wireless network
  • As soon as I put the batteries in my twine, my local wireless network gets extremely flaky. None of the laptops in my house can hold on to a wireless connection for very long, and general internet responsiveness goes in the toilet. As soon as I take the batteries out again, everything returns to normal. I do have the twine configured to connect to my wireless network, and I do see updates from it on the web site.

    Anyone else having this problem? It makes the twine completely unusable for me.

    Thanks!
  • 9 Comments sorted by
  • Yes, I have that as well. The only thing we can do is to change the channel of our WLAN. That is impossible in my case as there are so many other WLANs in the area that it took me ages to find the working channel I am on right now.
  • What channel ended up working for you? The wifi density in my area isn't too bad, so I have quite a bit of flexibility. Did you just keep trying different channels until it stopped kicking clients off the WLAN?
  • I had to change channels in order to execute the initial setup of TWINE. Since then I have had the dashboard working and sensor status displayed correctly, however no notifications when rules fire at all. Then I discovered that all other devices on the network lose connections and performance is poor, so I have re-boxed TWINE for now after removing the batteries to disable it.

    I have no idea if the issue with notifications is at my end or the server end, but the incompatibility with the wifi is a show stopper. Hopefully, a firmware upgrade can fix the issues later or else I have a blue rubbery brick.
  • Everyone who is having this problem, please log a ticket with help.supermechanical.com. I don't think they have the resources to monitor the forums, but I did get a prompt response from the help site [no solution yet, but a prompt response].
  • I opened one of my two Twines and see that it is using a GainSpan GS1011MIP WiFi module. This module uses the ancient 802.11b WiFi standard. This might be the cause of many of the reported WiFi problems.

    First, many WiFi routers have an option to enable/disable 802.11b support - if yours does, you'll need to make sure this is enabled.

    Second, it's common for an 802.11b device to cause problems for an 802.11n WiFi network it attaches to. All of the faster devices on that network need to use a slow request/grant process that is visible to the slow 802.11b device in order for that slower device to be able to see when it should be communicating. At best this "merely" slows down the peak capacity of the network. Worse, some of the otherwise well-behaved 802.11n devices might not be stable in this situation (though according to spec they should be).

    Not much we can do about that given the choice of WiFi module.
  • How much does this slow down the network? Does this mean the Twine is PERMANENTLY slowing down my entire network? Or just while it is trying to connect?
  • I have the same problem. I had to enable 802.11b and change from channel 13 to a more crowded channel, but network performance and stability is now worse for all devices.
  • I have exactly the same problem and therefore cannot use the Twine in my wireless network. Changing the channel didn't help.
  • I had the same experience when I first received my Twine in December.  I didn't look at the support forum at that time, but the effect was so immediate an noticeable that I pulled the batteries and put it on the shelf for a month or so.  Now I am trying it again, but so far I am not noticing as dramatic an effect.  Has something changed with Twine or is it something I have done differently this time?  That's what I am going to have to figure out.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!