Battery Life
  • It is now almost exactly 7 days since I received the "low battery" warning for my Twine, and it is still happily chugging along, showing 2.62 V. I believe in caution, especially in mission-critical situations, but I do think that for routine use the low voltage trigger level is set too high (it would be nice if users were able to set this level, based on the importance of what they are monitoring).
    I will continue to let the Twine run, monitoring it every few hours (but not overnight), and see roughly at which point it shuts down.
    Will keep you posted!
  • 16 Comments sorted by
  • I received my first low battery warning 11 days ago. Still kicking, current voltage is 2.52v.


    Granted, my twine has been sitting almost idle since, so YMMV.
  • Still going, at 2.57 V, roughly 8.6 days after low battery email.
    For the record, this Twine is running with moisture sensor plugged in, but dry.
  • Well, the twine apparently stopped working sometime before today, as there was no update in the past 24 hours, and the 2.39v reading I saw was just from the last good report received. When I removed the old batteries and measured them they were each about 0.75v. So, two weeks is perhaps my average battery lifespan so far.
  • ah ah
    i received my email notification today, a week after activation and to be honest this is the 2nd word i got from my twine. i set up a rule for temperature but seems not working (i guess there is a bug between C and F so my twine is lost even after few changes)
    anyway, I'm happy to see it is at least working for something : using battery and make me aware of it.
    I do not remember such in the specs I bought in a year ago
  • I'm sorry to say, mine seems like a battery-killer so far, even while only monitoring temperature. I put new batteries in, and less than a week later I got the "Low batteries!" auto email. It was around 2.8V at that time.
  • I have tried a fews sets now, not even 24hrs out a new set and I am getting the low battery message already. I am very disappointed with my Twine. I paid such a lot of money and then waited for 12 months for something that is not working.
  • My batteries, running just the standard mode of temp and orientation sensing lasted 8 days. Not all that great as battery life goes (maybe even poor).
  • Still haven't changed my batteries. Still reporting. 2.37v.


    Still sitting on a shelf.
  • I am at day 12 after the 1st low battery message, reporting 2.49 V.

    It is not clear if those of your reporting poor battery life are actually experiencing you Twin dying, of are simply believing the low battery message. If the former, it would be good to know what you were doing, if the latter, you need to know that the low battery message is being triggered at far too high a voltage, and I expect that Supermechanical will get around to addressing that issue in time.

    Further low battery messages (after the 1st one) seem to be triggered by the Twine "doing" something, ie. reporting a sensor transition, or by the owner updating rules.
  • The Twine went dead just about 12 days after 1st reporting "low batteries", with the last reported voltage being 2.45 V.
    The good news is it came right back up and reported within a few seconds after new batteries were installed.
    Also noted, with the new batteries, plugging in the moisture sensor causes a 0.02 V battery voltage drop, indicating that there is some current draw by the sensor. This remains constant, whether the sensor is "dry" or "wet". So, attaching a sensor does have a very small effect on battery life, but it does not seem to matter whether the sensor is "on" or "off".
  • Mine apparently is DOA and I never received an alert the batteries were low....WTH?
  • What is the "normal" voltage? What should I expect to see on a daily basis?  I got a low voltage warning at 2.62V
  • I put a pair of Energizer Ultimate Lithium batteries in and they lasted 6 weeks.
    This is with a mag switch going off several times a day. Would have lasted longer but I was playing around with vibration in fast mode which drains the battery real quick.
  • An update: After getting the announcement from Supermechanical about vibration sensing now being available, I decided to give it another try.

    I put new Duracell batteries in, and set up a vibration rule, to log triggers to a database. I left the Twine in "slow" update mode.

    AT MOST 72 hours after putting in fresh batteries, I got the "low batteries" alert email. During that time, Twine had logged maybe 20 hits to its vibration trigger.

    3 days of battery life equals an unusable Twine. As others have mentioned, part of the issue is having the low battery threshold set so high (2.8 V, I believe) - so I get the warning way too early, and don't change the batteries when they really need to be changed. But dropping 1/10 volt per day (if that progression remains linear) doesn't bode well for battery longevity.
  • How often is Twine supposed to update (in orientation top / slow mode)? Mine is blinking every 50 seconds even without something to set off the trigger.
  • I'm on day 17 of a fresh set of batteries, with the twine only monitoring temperature. The voltage is now at 2.39v and I haven't seen a report for 6 hours. It seems that once the voltage drops under 2.5v the reporting frequency drops also. I'll wait until tomorrow to see if it comes to life again.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!