How to connect to wifi network not broadcasting SSID
  • My home Wifi network does not broadcast its SSID, to make it harder for the average user to find. How do I enter the SSID manually so Twine can connect to it? It only shows me the Wifi networks in the area that broadcast their SSID, and I see nowhere to manually enter a Wifi network name.
  • 17 Comments sorted by
  • Follow Up: Just saw this via Supermechanical's Support Section:

    "Hidden networks also aren't supported, so we recommend you make your network visible and use the strong WPA2 security protocol. "

    http://help.supermechanical.com/kb/getting-started/setup-troubleshooting
  • I can't change my SSID between broadcast and non-broadcast as I have 20+ wifi devices and multiple base stations, and several client devices consider the network to be different when the broadcast value is changed; I don't want to have to reconfigure them all, and it's a possibility that Twine will not like it either.

    I tried using Firebug on Firefox to modify the html to post my network's ssid, but it still could not connect afterwards (3 slow flashes). Possibly the channel is not being set correctly.

    Beyond that, I wonder if the Twine even *can/will* connect to a network that does not broadcast its SSID.
  • Great. Wish I had known this before. :(

    For Sale: 1 very lightly used Twine . . .
  • I'm sorry, but after thinking about this for a while, I am mildly annoyed.

    I don't think it is within supermechanical's bailiwick to tell me how I should configure my network ("make your network visible"). I made it hidden for a reason (with WPA2 enabled, which is "strong" but not unbreakable), and the fact that the device cannot support a hidden network like most every other wifi device in the world simply means that the Twine is deficient.
  • FWIW - I had the same challenge. I finally had to broadcast my SSID to enable Twine to 'see' it. Once I broadcasted, I could select it. So I have *that* part figured out but I still can't get Twine to connect.
  • Christopher, I don't begrudge you your annoyance. Hiding your network won't stop someone capable of breaking WPA2 security, but it's not our intent to dictate what you should do, only suggest a remedy. This is a bug in our wireless chip's low-level firmware, and we will be working with the manufacturer to get it fixed.
  • Thank you for acknowledging it as an issue that may/will eventually be fixed. Is there a way for me to be notified when the firmware is fixed? How will I otherwise know?

    Regarding hidden network ids, I have a reason for why it is hidden, and regardless of whether I *can* un-hide it or not: "I have 20+ wifi devices and multiple base stations, and several client devices consider the network to be different when the broadcast [hidden/unhidden setting] is changed; I don't want to have to reconfigure them all" (as I pointed out earlier).
  • Chris -

    As a workaround until the firmware fix, what about picking up a cheap used wireless router just for Twine?
  • WHen they are fixing this, could you also fix it so they can connect to 802.11g networks that don't enable 802.11 or 802.11b data rates? (ie, 6, 9, 12+ but not 1/2, 5.5/11 ?). I'd like to think most modern homes have long since disabled legacy rates since there are few devices left in the world that need them.
  • don - our house requires multiple base stations to cover it and I am using channels 2,6, & 10. Adding another base station, even a cheap one, would interfere with the existing base stations and would only cover a portion of the house.
  • Please consider this another vote for support for hidden SSIDs. I just got my Twine yesterday and this was a rude surprise. I too hide my SSIDs and use WPA2 encryption to keep everything locked down as much as possible.

    I've had other devices in the past that couldn't connect, but exposing the SSID for a few minutes and configuring the device and re-hiding it worked for them. Not so for the Twine, it loses the network once the SSID is hidden again.
  • FYI Since I didn't see one, I added a Feature Request for this. Dunno if votes for this will help or not...
  • After reading this I conclude that the WiFi support in Twine is a piece of crap.
    Sorry I bought one.
    Gonna sell it on eBay and hope that WigWag is better...
  • Hiding your SSID name isn't a security feature...and sadly your 20+ wifi devices are giving out it anyway...

    http://www.howtogeek.com/howto/28653/debunking-myths-is-hiding-your-wireless-ssid-really-more-secure/

    I'll give you $50 for your twine.
  • The May 24 version of the radio firmware allows Twines to connect to hidden networks. To update your Twine, go to your account page, and click on "Upgrade to 2.0" under "Your Twines". 

  • Nobody is claiming that hiding SSID is a security feature.  However it *is* a simple privacy feature.  In any case, it's ludicrous that hidden vs broadcast is a problem for ANY WiFi device made in the last ten years.  Gimme a break.
    Also, I've burned through three sets of batteries trying to get this connected to my WiFi.  I have a whole box full of USB cables but not one of them has the micro- or whatever it is that this Twine requires for external power.  This device is not ready for prime time.
  • By the way I did the May 24 firmware update and confirmed my Twine has it, but it still can't connect to my hidden network.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!